1004 成绩排名 (20 分)

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

1
2
3
4
5
第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

1
2
3
4
5
6
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

结尾无空行

输出样例:

1
2
3
4
Mike CS991301
Joe Math990112

结尾无空行

题解:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include<stdio.h>
int main(){
struct{
char name[20];
char id[20];
int score;
}stu[1000];
int num;
int min = 101;
int index_min = 0;
int max = -1;
int index_max = 0;
scanf("%d",&num);
for(int i = 0;i < num;i ++){
scanf("%s %s %d",&stu[i].name,&stu[i].id,&stu[i].score);
if(max<stu[i].score){
max = stu[i].score;
index_max = i;
}
if(min>stu[i].score){
min = stu[i].score;
index_min = i;
}
}
printf("%s %s\n",stu[index_max].name,stu[index_max].id);
printf("%s %s",stu[index_min].name,stu[index_min].id);
return 0;
}